Possible Playback Failures

Incident Report for Screeners

Resolved

This has been resolved.
Posted Jul 08, 2026 - 19:17 PDT

Identified

Screeners is currently experiencing minor issues impacting video playback. There may be possible playback failures on some content. The issue has been identified and we are currently working on a resolution.
Posted Jul 08, 2026 - 12:20 PDT
This incident affected: Screeners App (Web Application, SafeStream, Magic Link Emails, Show and Episode Notifications, File Ingest) and tvOS App.